This section - Page 2 - Dodge Ram SRT-10 Forum
Reply
 
Thread Tools Display Modes
post #11 of 70 Old 12-11-2008, 07:20 PM
Coolenergy
Junior Member
 
Join Date: Jul 2008
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I hear you guys about how dealerships treat people. The guy that bought a ford over a dodge because of service is right on. I had a 2005 mustag gt before I bought my truck. My brother and I both run shops so I was at his store for a oil change and they found that my power steering hose was leaking. Took it to ford and before I knew it they were done and also found another problem with it which was my master cylinder cap. They ordered a new one and call me up for them to fix it. With my 05 rc I have to take it to my shop and find a problem and then tell the local dodge dealer what to fix. Since I have been doing business with them it has been in there 3 times for oil cooler lines 2 pinion seals one output shaft seal 3 calipers. Every time they fix something I have to re-inspect and usally bring it back because there fix did not do anything.
Coolenergy is offline  
Sponsored Links
Advertisement
 
post #12 of 70 Old 12-12-2008, 05:48 PM
viperhauler
Senior Member
 
viperhauler's Avatar
 
Join Date: Apr 2008
Location: In the bushes behind your house with my binoculars
Posts: 11,157
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
it must be a shop thing...i hear of dealers doing great or efffing everythning up...i've had great success with my dealer...they don't ever try to sell me that crap you don't need, and the only times it's been there, i've had it back next day...slave cyl, flush trans, flush brakes, change diff fluid, just reg maintenance stuff, and they seem to always have all the stuff to fix it in stock...

Dan-O
On the hunt...


Night Runner #327 RC

SOLD 02-2015: '04 RC #1150/3057
RIP 06-2012: '05 RC - Honorary 100k+ mile member


Quote:
Originally Posted by Midnight Runner View Post
I didn't let them wash my CE. But i did let them wash my son. LOL
viperhauler is offline  
post #13 of 70 Old 12-13-2008, 01:21 PM
ViperJeff
VIPEROLIGIST
 
ViperJeff's Avatar
 
Join Date: Jun 2007
Location: Viper Research Lab
Posts: 13,625
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
One thing that sould never be overlooked....


Does your dealer have a Viper Mechanic




Is your Viper Truck on the Viper Truck Registry?



“Success is not final, failure is not fatal: it is the courage to continue that counts.”
― Winston Churchill
ViperJeff is offline  
 
post #14 of 70 Old 12-13-2008, 06:11 PM
viperhauler
Senior Member
 
viperhauler's Avatar
 
Join Date: Apr 2008
Location: In the bushes behind your house with my binoculars
Posts: 11,157
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
i think 2 certified vm's

Dan-O
On the hunt...


Night Runner #327 RC

SOLD 02-2015: '04 RC #1150/3057
RIP 06-2012: '05 RC - Honorary 100k+ mile member


Quote:
Originally Posted by Midnight Runner View Post
I didn't let them wash my CE. But i did let them wash my son. LOL
viperhauler is offline  
post #15 of 70 Old 04-14-2009, 03:39 AM
Raines
Senior Member
 
Join Date: Apr 2009
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
New here and I hope this is in the right place. I'll try to make it short.

I have an '06 QC and started having problems about Sept. last year. My front brakes were sounding bad so I had the dealer order pads. When the dealer went to replace them, he discovered why they went out so quick. The calipers were sticking. Order new ones and replaced pads and calipers.

About a month later, brakes didn't feel right and brake light would come on about once a week (always before or after dealer hours), but would shut off when truck was shut off. Also had a little transmission slippage at lower speeds when letting off throttle and getting back on like the truck didn't know what gear to go into.

I took the truck in Nov. 2nd and went on a test drive with the service manager. (him driving) It slipped twice on the drive and I told him it doesn't slam into gear anymore like it used to. (they have never sold an srt-10 and mine is the only one taken there) I told him about the brakes and he said they felt fine. The next day I was called to pick-up the truck and was told everything was fine. I told him I was going to Vegas in a month I would take it to them while I was there.

Took the truck to Vegas and they gave it a quick diagnostic test and tried to give it quick fix as I couldn't leave it more than two days and they couldn't guarantee it'd be done by then. Said something wrong with a computer (said it has 7) and I was driving with power brakes out of the 70's. Took printout from Vegas to local dealer.

Was given the truck back 4 times during a monthlong period and only once did I make it out of the lot. (for 12 hours to drive it home and then to work the next morning)

Was finally given the truck back after 27 days and told it was okay to drive even though engine light stays on and brake light comes on constantly. Made then put it on paper. They said a computer was bad and they found a flaw in them, but wouldn't be making more until more trucks needed them replaced.

I've been driving the truck this way for approx. 6 weeks now and it runs rough, brakes drag when backing up, navigation doesn't work, and of course dealing with the constant beeping from the engine light, brake light, and navigation message.

Finally called Chrysler service and been given a case number and told to drop truck off at dealership and ask for a rental car and say nothing else (after they looked up the records) as the district manager would handle the rest.

Anyone else having these kinds of problems?

Last edited by Raines; 04-14-2009 at 03:44 AM.
Raines is offline  
post #16 of 70 Old 04-14-2009, 07:53 AM
ViperJeff
VIPEROLIGIST
 
ViperJeff's Avatar
 
Join Date: Jun 2007
Location: Viper Research Lab
Posts: 13,625
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
WOW...


No I haven't, what dealer have you been taking it to, maybe we can help find a better one in your area




Is your Viper Truck on the Viper Truck Registry?



“Success is not final, failure is not fatal: it is the courage to continue that counts.”
― Winston Churchill
ViperJeff is offline  
post #17 of 70 Old 04-14-2009, 08:08 AM
Raines
Senior Member
 
Join Date: Apr 2009
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Viperam2 View Post
WOW...


No I haven't, what dealer have you been taking it to, maybe we can help find a better one in your area
Fisher Dodge. It's the only Dodge dealer in my town. The next closest would be 2 1/2 hours either east or west whichever town I decided to go to.

I would love to leave it with the Vegas dealer I bought it from, but it's not really feasable. I told my local dealer last time I took it back to them, (after driving through their parking lot) I don't care how long it takes, just fix it! Like someone else said, the service adviser didn't even know how to start it. They even drove it out to give to me the first of the visits with the engine light on.
Raines is offline  
post #18 of 70 Old 04-14-2009, 11:27 AM
viperhauler
Senior Member
 
viperhauler's Avatar
 
Join Date: Apr 2008
Location: In the bushes behind your house with my binoculars
Posts: 11,157
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
thats terrible!...as far as the problems go, i don't know what to say...other than you need a new dealer...

Dan-O
On the hunt...


Night Runner #327 RC

SOLD 02-2015: '04 RC #1150/3057
RIP 06-2012: '05 RC - Honorary 100k+ mile member


Quote:
Originally Posted by Midnight Runner View Post
I didn't let them wash my CE. But i did let them wash my son. LOL
viperhauler is offline  
post #19 of 70 Old 04-14-2009, 11:49 AM
Raines
Senior Member
 
Join Date: Apr 2009
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
According to the dealer, or what they said Dodge techs. told them anyway, is it's a bad batch of computers that control the o2 sensor. They said I'd have to wait until they needed more as they wouldn't make just 1, they would need to make a bunch at a time. So I'm screwed until they get some more complaints basically.

They replaced that computer once and also the TPIM, but it didn't solve it.
Raines is offline  
post #20 of 70 Old 04-14-2009, 12:48 PM
viperhauler
Senior Member
 
viperhauler's Avatar
 
Join Date: Apr 2008
Location: In the bushes behind your house with my binoculars
Posts: 11,157
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
i'd be effin irrate!!!!!!!

Dan-O
On the hunt...


Night Runner #327 RC

SOLD 02-2015: '04 RC #1150/3057
RIP 06-2012: '05 RC - Honorary 100k+ mile member


Quote:
Originally Posted by Midnight Runner View Post
I didn't let them wash my CE. But i did let them wash my son. LOL
viperhauler is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome