SRT10 Forum banner

1 - 14 of 14 Posts

·
Banned
Joined
·
8,596 Posts
Discussion Starter #1
On the passenger side, right at the wheel opening I have a ridge that runs the entire length of the air dam. I looked at a red QC that was at the dealership and it had the same ridge. Looks to be something in the mold. Was going to have them replace it until I seen it on the other one.

Does anyone else have this problem? They have to repair the air dam anyway because it looks like it scraped on the ramps of the transporter when they unloaded it. If there are good air dams out there I will just tell them to replace it.

Thanks
 

·
Registered
Joined
·
966 Posts
Silverback...

Silverback said:
On the passenger side, right at the wheel opening I have a ridge that runs the entire length of the air dam. I looked at a red QC that was at the dealership and it had the same ridge. Looks to be something in the mold. Was going to have them replace it until I seen it on the other one.

Does anyone else have this problem? They have to repair the air dam anyway because it looks like it scraped on the ramps of the transporter when they unloaded it. If there are good air dams out there I will just tell them to replace it.

Thanks
Are you talking about the bottom part of the air dam...? there is a bulbous ridge at the bottom and wraps across to the other side?
 

·
Registered
Joined
·
966 Posts
Silverback...bottom ridge

i was looking at your posted pics...the bottom ridge...its supposed to be there.
 

·
Banned
Joined
·
8,596 Posts
Discussion Starter #4
Actually it's on the drivers side, not the passenger. One to many beers that night.

I will take a picture tonight when I get home and post it. Since it's only on one side I do not believe it's supposed to be there.
 

·
Registered
Joined
·
1,803 Posts
I would be interested to see this, I don't think I have this :confused:
 

·
Banned
Joined
·
8,596 Posts
Discussion Starter #6
Okay, here are the pictures. You can see it in the first picture, but this also shows where I'm talking about. The second picture is a closeup of the area.

I got caught in the rain today so the truck is dirty. Damn.
 

Attachments

·
Registered
Joined
·
966 Posts
no worries

Silverback said:
Okay, here are the pictures. You can see it in the first picture, but this also shows where I'm talking about. The second picture is a closeup of the area.

I got caught in the rain today so the truck is dirty. Damn.
TSK TSK,,,in the rain you say? oooo! As Austin Powers says, You too like to live dangerously, take chances eh? In the rain, Wa drivers....that's as bad as driving and drinkin'...ok almost..

Silver,
no worries...I just checked mine and it looks like part of the mold...its decorative.
I think yours might be more pronounced due to the color or dirt? Oh shaem of it all...a dirty yeller fever...heh heh.
Mine is Red and looks like just a hint of something there......probably cuz i wax that dang thing sooo much :D :D
but I don't believe it is not a flaw as you may think. no worries.

dallas
 

·
Banned
Joined
·
8,596 Posts
Discussion Starter #8
I guess I wouldn't mind as much if it was the same on the other side, but it's not. That's why I think it's a flaw in the mold. They still need to repair the scrapes on the bottom, so I will have them fix this at the same time. Kind of hate to have any paint work done, but if they screw it up, they can keep doing it until they get it right.

Thanks for looking at yours and passing along what you found.
 

·
Registered
Joined
·
966 Posts
Silverback

I went out this morning and looked at the driver side..I was looking at the passenger side last night...
yep you are right, it is more pronunce on the driver side than the passenger side..for me, i look at it like i said as a decorative touch :D ...i haven't had anyone say, nice truck but that mold line is a bit out of tolerance eh?
(ok don't start in you all)...your truck looks great...just don't mention it to anyone..ooops, i guess we did now... :eek:

dallas :cool: :D
 

·
Banned
Joined
·
8,596 Posts
Discussion Starter #10
You mean you don't feel the Aero Drag to the left at speed. ;)

Like I said earlier, they have to repair the air dam anyway because of the transporter damage and I'm also going to have them fill the holes from the license plate mounting bracket. They may as well fix this also and repaint the entire air dam. Just hope the color matches the rest of the truck when they are done.
 

·
Registered
Joined
·
966 Posts
Silver...

Aero Drag...? well yeah...i guess that is why i keep doing donuts spinning to the left!
Good luck with the repars...It was nice meeting you yesterday! Wow..I saw the yellow viper out off the showroom floor in the parking lot but from my point of view, I thought it was a truck sitting there waiting to be sold...Yet as you said, after i pulled up ---you knew who I was. by the badging etc....you had the advantage..recognizing my truck... :D
well gotta get to a meeting...
I changed my lic plate from HAWTRAM to BADVIPR...just got the updated registration for it yesterday.

Later,
Dallas :)
 

·
Premium Member
Joined
·
239 Posts
I have the same "beauty lines" on my Silver QC. Both sides are the same.
 

·
Banned
Joined
·
8,596 Posts
Discussion Starter #13
Well I have an update on the air dam(n). I dropped it off at the dealer on Monday, March 28th. The repair was supposed to take 2 days. They were going to fix the scrapes in the bottom lip, the "beauty marks" on the wheel well openings and reallign it. It was shifted off center about 1/2 inch. They also agreed to fill the 3 holes from the front plate bracket. Well they did not finish it up until late Thursday, so I could not pick it up until Friday. Looked it over and overall they did a nice job. Almost.

This Saturday turned out to be nice so I decided to clean it up and put a couple coats of Zaino on it. Washed it and pulled into the garage to clay bar it. Came to the left front fender and here is this big blob of paint about the size of your thumb nail. :confused: :eek: WTF? :mad: While they were fixing the air dam they scratched the fender and then tried to hide it. :mad: Took it back to the dealer on Saturday and was not much they could do as the service manager was off, although the sales manager was not to happy. I need to add that they do not have their own bodyshop and farm it out to another dealer so technically they were not responsible. Now it looks like they will have to paint the entire fender to clean it up. Damn. I guess I would have been better off just living with the way it was.

Sorry for the long rant, but now I feel better. Thanks for listening.
 
1 - 14 of 14 Posts
Top