SRT10 Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I took mine into the dealership last week for the serpentine belt squealing. The Service Mgr. @ Bankston Dodge in Irving,TX told me that the tensioner pulley was bad and they ordered a new one. Then 2days later they said that the new one was a completely different size than the one that was on the truck and the mounting hardware was different and they needed to order a bolt to mount it. 2 more days later they said that the harmonic balancer was bad and that the original tensioner pulley was fine and they had to order a new harmonic balancer. Finally, I picked it up yesterday and was told that the Harmonic balancer had backed off some and had caused the belt to be off-line from the other pulley's and so they just retightened it and put a new belt on. The truck has 10k miles on it and I have never heard of this happening to anyone else. Please let me know what your thoughts are and if I should be worried about any other kind of damage from the harmonic balancer being off track. Thanks for any input. Jay.
 

·
Registered
Joined
·
256 Posts
front seal

Have them check the front seal too. If the balancer work it's way out it could have damaged the oil seal. ML
 

·
Registered
Joined
·
1,803 Posts
**** happens, I was talking to Sean @ Roe when they were setting up there SRT-10 Ram for the supercharger they found the pulley on the crank was missing bolts and the ones that remained were finger tight.!!! ;) So while we look and admire or trucks we should also check around. :D
 

·
Registered
Joined
·
2,850 Posts
Whew..thats why i was actually pleased to have an Arrow rebuild. Of course I've been noticing a squeel lately. Silly me...I just thought it was a loose belt ;)
 

·
Registered
Joined
·
974 Posts
womsterr said:
Whew..thats why i was actually pleased to have an Arrow rebuild. Of course I've been noticing a squeel lately. Silly me...I just thought it was a loose belt ;)
Wormsterr,
Do you have a link to Arrows website? Also have you tested the headers out yet?
 

·
Registered
Joined
·
2,850 Posts
They don't have a website brudda but if you pm me I'll email you Todd's numbers at Arrow. They handle all the factory rebuilds...
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Thanks for the comments guys. I guess this shows how well DC's QA team is working.
 

·
Registered
Joined
·
2,911 Posts
rofd41 said:
Thanks for the comments guys. I guess this shows how well DC's QA team is working.
Make sure it's the belt. I have an upper idler pulley bearing goe bad and it sounded similar to a belt slipping. Changed the pulley and all is fine!
 

·
Registered
Joined
·
241 Posts
I am having minor squeal when the engine is cold, right after slow take of till about 5mph.. Anyone have any ideas what his could be?
 

·
Registered
Joined
·
1,490 Posts
Likestospeed said:
I am having minor squeal when the engine is cold, right after slow take of till about 5mph.. Anyone have any ideas what his could be?

Mine has developed the same thing...although I am noticing it some now even when I am driving..... I plan to take it in and have them check it out.
 

·
Registered
Joined
·
205 Posts
I have noticed mine while driving on the highway. At first I thought it was the wind - because I didn't hear it at slow speeds. But the more I listen to it the more I think it sounds like a belt.
 

·
Registered
Joined
·
2,911 Posts
mmmmtorque said:
Mine has developed the same thing...although I am noticing it some now even when I am driving..... I plan to take it in and have them check it out.
Exact symtoms I had!!
 

·
Registered
Joined
·
1,490 Posts
Marc T said:
Exact symtoms I had!!

OK, good reference....It does sound more like a bad pulley than just a normal belt slip. I will post the results after I visit the dealer...Had to go anyway to have them redo my oil change (another victim of the dealer 11 qt service) :mad:

beaver dam muther fudgers!
 

·
Banned
Joined
·
4,013 Posts
I remember a thread on this somewhere, maybe someone else knows. But seems like a few people had the belt squeal, and the lower pully was cracked. Now I didn't read this whole thread so if has allready been mentioned I aplogize, ya'll can call me dufus!!!!!! :D
 

·
Registered
Joined
·
241 Posts
I'm taking it in on Monday to have them check.. When it was warm for a couple days I didn't notice it but when it is cold it sounds like ****. Damn this to happen to a new truck.
 

·
Registered
Joined
·
12 Posts
i think my belt is screwed too, for the last week when i start the beast the belt squeaks for about 2 minutes, or until it heats up. I am taking this piece of crap back and trading it for a rumblebee!

F**K that just kidding i love this truck, am taking it to the shop tomorrow
 

·
Registered
Joined
·
241 Posts
mak9177 said:
i think my belt is screwed too, for the last week when i start the beast the belt squeaks for about 2 minutes, or until it heats up. I am taking this piece of crap back and trading it for a rumblebee!

F**K that just kidding i love this truck, am taking it to the shop tomorrow
Yeah you got the same thing I got, only mine has been doing it almost since I took delivery with less that a mile on the truck. Wish these fudgers cold get this right, it seems to be a pretty regular problem. Maybe a recall is in order.
 
1 - 20 of 23 Posts
Top