SRT10 Forum banner
1 - 20 of 31 Posts

Registered
Joined
29 Posts
Discussion Starter · #1 ·
Hey guys, need some help troubleshooting a clicking sound coming from truck.
About a week ago I noticed there was a constant clicking sound (every few seconds) coming from somewhere underneath my Ram SRT-10 when it's turned off and just sitting there.

The sound is not the exhaust cooling down because I hadn't driven the truck in a few weeks. The truck starts right up, runs fine, but as soon as I turn it off and get out I can here the click. I'm not sure if it's doing it while I'm driving, between the Belanger headers, Magnaflow exhaust, and CAI there too much noise to isolate the click.

Anyone experience this before? Anyone have any ideas what it might be?

Thanks!
 

Premium Member
Joined
36 Posts
I'm sure someone may disagree with this, but from my understanding the clicking sound is simply... Metal components in the driveline are cooling and contracting thus making the noises you are hearing and are normal.
 

Registered
Joined
195 Posts
After your 10 has set overnight & hasn't been started does it still make the sound? If it does, it shouldn't have anything to do with it cooling down. It would have to be something else.
 

Registered
Joined
29 Posts
Discussion Starter · #5 ·
Guys I appreciate your replies, but please read my post. It has nothing to do with cooling down. The truck hadn't been driven in a few weeks and was making the clicking sound.
 

Premium Member
Joined
36 Posts
It could be solenoids firing on and off for some unknown reason. Loosen the Neg cable from the battery get the truck to start doing it then remove the Neg cable and if it quits then you know theres a short in the system. Do you have a check engine light on? And maybe not be a **** to those trying to help you.
"The truck starts right up, runs fine, but as soon as I turn it off and get out I can here the click. I'm not sure if it's doing it while I'm driving" is what you said! Maybe be more specific with what you say. Want me to word it for you?
After the truck sits overnight I turn the key to ON and then I hear some clicking noises from underneth. Does anyone know what this could be? BOOM Done!! You're welcome!!
 

Registered
Joined
29 Posts
Discussion Starter · #10 ·
disconnect the battery after you turn it off and see if it still does it.
Thanks, I'll try that and see if the clicking stops.
 

Registered
Joined
29 Posts
Discussion Starter · #11 ·
It could be solenoids firing on and off for some unknown reason. Loosen the Neg cable from the battery get the truck to start doing it then remove the Neg cable and if it quits then you know theres a short in the system. Do you have a check engine light on? And maybe not be a **** to those trying to help you.
"The truck starts right up, runs fine, but as soon as I turn it off and get out I can here the click. I'm not sure if it's doing it while I'm driving" is what you said! Maybe be more specific with what you say. Want me to word it for you?
After the truck sits overnight I turn the key to ON and then I hear some clicking noises from underneth. Does anyone know what this could be? BOOM Done!! You're welcome!!
Thanks for the info... I wasn't intentionally trying to be an a**** to anyone, if anyone felt that I was, my sincere apologies.
 

Premium Member
Joined
2,599 Posts
I'm also thinking it's a relay or battery trickle charger or something else electrical. My '06 QC sits quietly when it's resting cold so I can't think of anything else it could be. You could try disconnecting the negative battery terminal and jumping it with a meter just to see what kind of amperage/voltage it's pulling.
 

Premium Member
Joined
715 Posts
Not trying to be an ass but have you checked for vermin. I have seen cars where mice and squirrels have gotten in and there is not much left of the electrical systems after they are done chewing on them.
 

Registered
Joined
20 Posts
I also had a solenoid clicking sound under the drivers seat and it turned out to be the usb adapter I put in the cigarette lighter.
 

Registered
Joined
29 Posts
Discussion Starter · #18 ·
I'm also thinking it's a relay or battery trickle charger or something else electrical. My '06 QC sits quietly when it's resting cold so I can't think of anything else it could be. You could try disconnecting the negative battery terminal and jumping it with a meter just to see what kind of amperage/voltage it's pulling.
I don't drive the truck often, so I have a Battery Tender plugged into it. This past weekend I unplugged the battery tender so I could roll the truck back far enough to get my motorcycle out. I haven't plugged it back in, but the clicking sound is gone. So it may very well be the trickle charger!
 

Registered
Joined
29 Posts
Discussion Starter · #19 ·
Not trying to be an ass but have you checked for vermin. I have seen cars where mice and squirrels have gotten in and there is not much left of the electrical systems after they are done chewing on them.
I thought that too initially. Even got under truck with an led flashlight and looked around for any evidence of vermin. Fortunately that wasn't the case. :)
 

Registered
Joined
29 Posts
Discussion Starter · #20 ·
I was thinking maybe he has a clock in the garage that was ticking. Happened to me before, was wondering what the heck it was!:pat:
lol... No clock in the garage
 
1 - 20 of 31 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top