SRT10 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1 (Edited)
whats going on guys, couple of days now i noticed that my truck started to run hotter than normal. I looked at the cooling fan and it does not seem to spin fast. After looking into the problem i noticed that my power steering pump is making a whining sound when i rev the truck and turn the steering side to side. The fluid level is OK. Anyone out there had this problem? Do you guys think its the pump?

Thanks Guys!!
 
Joined
·
8,725 Posts
possible pump going bad, but a pressure check is in order to confirm
 

·
Site SUPER Moderator
Joined
·
6,688 Posts
I had the same thing going on with Both of Mine... :)

The cooling fan on our trucks is Hydraulic and is powered by the power steering pump. If it gets low on fluid or starts to go bad then there is not enough fluid or pressure to power the fan...

Get a new PS Pump put on and a set of Tony's PS Lines and you will be fine.... :) :) :)

I have replaced both of my PS Pumps then the last 3 months and both are fine now... :) :)
 

·
Site SUPER Moderator
Joined
·
6,688 Posts
Don't just go out and buy ANY PS Pump... These Trucks don't use the Standard PS Pump for a Hemi or anything like that... You need to make sure it is for SRT-10 Truck and Not the Viper SRT-10.... Most Dealers or Auto Parts Stores will have to Order it In... :) :) :)

They also come as "JUST The Pump" (Without Tank) and Complete Unit (With Tank)...

Also Unless your are REAL Good at swaping out the Tank on the PS Pump (there are a few things you need to Know and Do to swap the tank out) Get the one that comes complete with Tank. You will also want a "Crows Foot" Wrench with Extention to get to the Top Hose Connection... :) :) :) :)
 
Joined
·
8,725 Posts
cool, dont get a autozone pump for sure, we have had tons of problems with them bo, oem is the best
 

·
Premium Member
Joined
·
6,854 Posts
Tony, how much is it for a new pump complete with tank?
 

·
Registered
Joined
·
94 Posts
Discussion Starter #10
I don't think the dealer have them new, it looks like they are having them rebuilt because they need me to take in my core
 

·
Site SUPER Moderator
Joined
·
6,688 Posts
At this point of the Game, I think All of them are Rebuild/Remanufactured.... Remember the Newest ones are 6 years old.... :) But Most Deff use OEM MOPAR.... Never a Knock-Off.... :) :) :) :)
 

·
Registered
Joined
·
2 Posts
Hello I'm new to this site I've been having a problem with temp rising to 230 when on idle and once I start to drive again temp goes back to normal any suggestions
 
1 - 14 of 14 Posts
Top