SRT10 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
started it up last nite, it had a loud tapping noise coming from drivers side upper part of engine. oil pressure was good, it had been sitting for several days, and a night of
-10 degree befor i got heater up and running in barn.
i turned it off, restart ...same, turned it off and then it was fine. !! WTF this worries me, only has 19 miles on it and i've only driven it a few feet, literally.
55 and snow gone today, thinking about taken her out this afternoon??
any ideas on the noise?
 

·
Premium Member
Joined
·
1,427 Posts
it is just bleed down because it sat for so long but it should not have lasted more the 10 seconds especially is 55 degree temps. these engines do have a sustained tap (sounds like loud fuel injectors and very well maybe) at idle and maybe that is what you were hearing.. Take it out for a 400 mile run :D and get those nternal parts saturated with that oil :cool:


Site :cool:
 

·
Banned
Joined
·
4,013 Posts
Just my 2 cents but the oil had probably drained out of the lifters from sitting, that with the cold temp thickening the oil up, would cause a tapping of the lifters for a minute or two until lifters pumped up. Even though you warmed the barn up it would take awhile to warm the oil in the block. My thing would be check the level, let the truck warm up to operating temp, check oil pressure. Then drive it and make sure everything is allright. More than likely you are fine. Mine sets for weeks at a time sometimes, in the what we consider cold here, about 30 degrees. It will tick for a minute or two until the oil gets completely circulated thru the engine. If you crank it every other day and let it get to op temps, You probably won't here the noise anymore. But let it get to op temp, because condensation in the exhaust needs to completely burn or dry out so as to not rust your pipes. Hope this helps. :D
 

·
Registered
Joined
·
144 Posts
Inherent characteristic with this engine. Started mine 2 days ago after minus 28 degrees for 3 nights. Battery very strong after sitting 3 weeks. Don't worry about the tapping-go have fun!
 

·
Registered
Joined
·
4,025 Posts
QUICKSILVER said:
What tapping? I hear nothing! A little whistle maybe...... :D

:cool:
Quick;-)

supercharger showoff!!!!!!!!!!!!! :mad: ;)


patrick
 

·
Premium Member
Joined
·
239 Posts
Just got my SRT-10 5 days ago and I have noticed the tapping at idle whether hot or cold. So this is normal as Sitedrifter noted? Does anyone know what this is?
 
1 - 7 of 7 Posts
Top