SRT10 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17,270 Posts
Discussion Starter #1

·
Registered
Joined
·
4,025 Posts
I have seen that episode twice and yes I taped it this time to watch it again. This time as a owner!!!! Nice!!! :D :D :D

patrick
 

·
Registered
Joined
·
17,270 Posts
Discussion Starter #3

·
Banned
Joined
·
1,977 Posts
Yep - I saw it too! (What, I thought I was the only one that laid around on my azz on Saturday afternoons?? :confused: )


Stacey got me all fired up, so tonight I went out and 'practiced' my launch technique - ;). I tried 'riding it' from a stop at about 3,500rpm's to see if I could launch without bogging and,,,,






,,,, the focker started slipping through 1st and 2nd. :mad: So I just took it easy and drove back home. It'll probably be better once it cools off. Earlier it was chirping 2nd and 3rd!

That damn clutch is stinky!

(Just turned 3,600 miles FWIW - Centerforce in my future - maybe?)
 

·
Registered
Joined
·
17,270 Posts
Discussion Starter #5

·
Registered
Joined
·
1,024 Posts
Hamrhead said:
Yep - I saw it too! (What, I thought I was the only one that laid around on my azz on Saturday afternoons?? :confused: )


That damn clutch is stinky!

(Just turned 3,600 miles FWIW - Centerforce in my future - maybe?)
Hamr, Just install the Centerforce w/o any slave cylinder upgrades, wrap the lines and move them away from the heat source, upgrade to Motul 6 fluid, and put in a new throw-out bearing, the clutch will chatter for approx 300 miles or so, but will ROCK after that. One black has that setup the other black has the same setup as boomer (minus the lightweight flywheel). The only difference I notice between the two setups, is I can let the clutch out at idle and roll smoothly with the upgraded cylinders. W/O it, the truck lunges forward and stalls.

I can drive it hard ALL day, and still smoke the tires through 3rd. It is so strong, that when I down-shift into 1st at 40mph, the tires lock up and I slide into the stops, and smokem leaving....

Craig
 

·
Banned
Joined
·
1,977 Posts
Thanks for that info Craig, but not just yet. Today I hopped in and all was normal again - Burnin' rubber and chirpin' gears! :D

If it keeps happening, I'll most likely go that way though.

Thanks again! :cool:


FWIW, with everything stock I can ease out on the clutch, from a stop, and idle along smoothly. Never had a problem with that.
 
1 - 7 of 7 Posts
Top