SRT10 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter #1
Anyone have problems with their oil sensor, Mine's in the shop. The Check Gauges light kept coming on. When Idling the oil gauge was almost at zero. I'm driving a Hyandai Loaner.
 

·
Banned
Joined
·
1,977 Posts
Nope - not yet. Mine is usually around half-way at idle (Think that's 50psi or so), and goes up at higher RPM's.



Don't let that Hyundai get away from you, and don't get used to the gas mileage either. :rolleyes:
 

·
Registered
Joined
·
139 Posts
Discussion Starter #4
Hamrhead said:
Nope - not yet. Mine is usually around half-way at idle (Think that's 50psi or so), and goes up at higher RPM's.



Don't let that Hyundai get away from you, and don't get used to the gas mileage either. :rolleyes:
Don't worry. I feel like my ass is scraping the pavement
 

·
Registered
Joined
·
139 Posts
Discussion Starter #5
Lucifer said:
More than likely it's your oil sending unit, used to go out in my Dakota R/T at least once a year. :mad:

Thanks. I beleive when they worked on the can bolt, they may have messed up the sending unit. Oh well, in the meantime I'm loving the good gas mileage.
They needed a special tool to remove the sending unit, so they kept it over the weekend.
I used to have a R/T also. Never had a problem with it.
Taking a trip to Birmingham from Orlando next Sunday. Hope there is no more problems. Other than that I love the truck and can't wait to stretch its legs.
 

·
Registered
Joined
·
77 Posts
i noticed this weekend when i was fixing my slave line (using the zip tie method from this forum)i noticed a oil leak .first one i saw a little drip from the drain bolt ,nothing big ,i also saw oil runing down the passenger side of the block down on the bellhousing,maybe its from the valve cover gasket, it is not alot of oil .its coming from somewhere on the top of motor.just a few drips.when i take it in for its service ill have them check it.any of you guys have oil leaks?
 

·
Registered
Joined
·
139 Posts
Discussion Starter #7
gto19 said:
i noticed this weekend when i was fixing my slave line (using the zip tie method from this forum)i noticed a oil leak .first one i saw a little drip from the drain bolt ,nothing big ,i also saw oil runing down the passenger side of the block down on the bellhousing,maybe its from the valve cover gasket, it is not alot of oil .its coming from somewhere on the top of motor.just a few drips.when i take it in for its service ill have them check it.any of you guys have oil leaks?
No oil leaks, however, it wasen't the oil sensor. They now have to pull the pan. It could be a by-product of the cam bolt recall. If so, I'll let you guys know. whatever it is, if its not a unique problem to my truck, then it will be another heads up for a future Service bulletin or recall. Whatever it is, I hope they get it fixed and its nothing major.
My truck has 3,000 miles on it, so if you guys notice a drop in oil pressure and your check gauges light comes, no that you not alone.

This Hyundai has 1/8 a tank of gas and still going. I'd rather be halling ass and sucking gas !!!!
 

·
Registered
Joined
·
139 Posts
Discussion Starter #8
OIl Pressure Releif Valve

They found a Burr (Debris) in the Oil Pressure Relief Valve and was causing it to stick. Don’t know how it got there unless when they did that cam bolt fix, a piece of debris got in the engine. They change the relief valve, cleaned the area and the oil pressure is back to normal. They really had to deep in the engine to get at it, so they said. I’m back on the road again. They even detailed the truck (wash & wax) before they returned it to me.
 

·
Registered
Joined
·
974 Posts
Glad to hear your back on the road... I think they owe you more than a wash and wax... Let's say free oil changes for the next year... :D
Oh yeah and one big slap up side the head for giving a SRT -10 owner a Hyundai for a loner.... What a dam insult... Man not sure if I would of waited to slap the dumbass that brought me a Hyundai around and said heres your loner till we get your truck done... *biff* upside the head NOT!!!!, try again A-hole... yeah that red 300c will work.. :cool:
 
1 - 9 of 9 Posts
Top