SRT10 Forum banner

1 - 20 of 70 Posts

·
Registered
Joined
·
1,494 Posts
Discussion Starter #1
This section is one central place to post problems with dealer service. Now when good guys (like I know we all are) have problems, they can post here and maybe we can help each other out. NO WITCH HUNTS and please keep posts focused on DEALER issues. Use "general discussion" for other vendors. Let's hope this section doesn't get used very much.:D
 

·
Registered
Joined
·
150 Posts
Oil change blues

Well I took my SRT 10 down for it's first oil change to my dealer. To start off they take the truck in, drop the oil and then find out they have no oil in stock. They wanted to put some other brand of regular oil in it but I said no way.
So there parts runners were out for at least 2 hours and I wanted to get the heck out there, so the service manager says that he'd let me take his Jeep out to get the oil (Mobile 1 of course) So I head out, get the oil and they finally finish the oil change. Well I get home and the next day I checked the oil and find it 4" above the maximum level of the dip stick. I realize that these dip sticks aren't the easiest to read but that is a little to much. Anyway I drain off a half pint and brought it back to the proper level.
I would think that these guys are suppose to be the professionals but this didn't give me to much confidence in their skills or mickey mouse inventory system. I didn't want to raise to much **** with these guys just in case I need some warranty work down the road but they suck.
 

·
Registered
Joined
·
1,343 Posts
Dealer service?

Poor dealer service is why I just purchased a new Ford Ranger instead of a Dodge Dakota. I like the Dakota better but have had such miserable treatment at Dodge Dealers, (with no explination, as I was later told would happen) I just gave up.I do not buy as many new vehicles as Craig does but I have purchased 8 new vehicles since 1997 so I guess I am good for at least 1 per year. I also am asked by neighbors, family and friends what I think about various makes. What do you think I will tell then. I will be buying my wife a new car in the next year and once more it will not be a DaimlerChrysler product. I will be buying a Diesel truck to tow my Dodge around the country and am looking at the Ford Harley Davidson F250. I wonder what folks will think when I pull into a track towing a Dodge with a Ford. A close friend purchased a new HD Ford last year. It had engine driveability and running problems. Ford treated him very well as I was at the dealer with him several times. Dodge needs to take lessons from the other car companys regarding customer relations. Dodge has a good product but they have a serious customer relations problem. The customer service hot line at Dodge is a unplesant experiance. I hope someone from DaimlerChrysler reads this and takes note and follows up, as no one so far has done so. Just my two cents.........Jack
 

·
Registered
Joined
·
7 Posts
My 2005 CE still vibrates between 65 & 85. Dealer replaced tires, special balancing, rims, after 4 trips for service. At 120 it vibrates more but not all the time. Dealer says it goes with having SRT10 truck 6 speed. Dealer claims quad cab SRT10 rides smooth because its set uo different. Every time I bring it in, dealer claims trouble fixed with high speed balance, then says driving at 120 mph is illegal besides being dangerous. Ready to pull out my hair...............if I had any left.
 

·
Registered
Joined
·
3,195 Posts
VIPERED said:
My 2005 CE still vibrates between 65 & 85. Dealer replaced tires, special balancing, rims, after 4 trips for service. At 120 it vibrates more but not all the time. Dealer says it goes with having SRT10 truck 6 speed. Dealer claims quad cab SRT10 rides smooth because its set uo different. Every time I bring it in, dealer claims trouble fixed with high speed balance, then says driving at 120 mph is illegal besides being dangerous. Ready to pull out my hair...............if I had any left.
The dealer is full of ****, I have a quad cab an dhave the same thing and several prople here on the site have complained about the same thing. Some have been able to fix it and some not I think. If yours is like mine, it's intermittent, even between 65-85, at least mine is. Since it doesn't do it all the time I've ruled out tires rims etc and just figured it's some characteristic of the tires or something. Maybe an old fahsioned tire place could help figure out what it is, doesn't sound like the dealer is going to find it.
 

·
Registered
Joined
·
186 Posts
Guys, have them check the drive shaft. iI had the same problem with mine. I ended up pulling the drive shaft and taking it to a local drive line shop. They found the shaft to be .035 bent, they strainted it and the problem was solved. The dealer claimed they checked it and the drive line was fine, but when I showed them the recipt it was a differnt tune. They took care of the cost to me for the repair. Only problem with that I told them , is they should have done that in the first place when i asked them to check it and not lie to me and tell me it was fine.
 

·
Registered
Joined
·
3 Posts
how do u guys get the dealer to warranty your trucks even w mods and he superchargers? I have 05 QC w/ a paxton and cant get a dealer to touch it!
 

·
Registered
Joined
·
451 Posts
slamdxterra said:
how do u guys get the dealer to warranty your trucks even w mods and he superchargers? I have 05 QC w/ a paxton and cant get a dealer to touch it!
If you got a charger on you don't have much of a chance,,, mine isn't warrantied due to my supercharger and i blew my engine... it sucks but i know you gotta pay to play. :)
 

·
Registered
Joined
·
16 Posts
avmech said:
Guys, have them check the drive shaft. iI had the same problem with mine. I ended up pulling the drive shaft and taking it to a local drive line shop. They found the shaft to be .035 bent, they strainted it and the problem was solved. The dealer claimed they checked it and the drive line was fine, but when I showed them the recipt it was a differnt tune. They took care of the cost to me for the repair. Only problem with that I told them , is they should have done that in the first place when i asked them to check it and not lie to me and tell me it was fine.
hey i have an 05 qc i noticed you said you have pulleys could i have a set installed on my qc? and if so how much and where can i get them!
 

·
Registered
Joined
·
24 Posts
I hear you guys about how dealerships treat people. The guy that bought a ford over a dodge because of service is right on. I had a 2005 mustag gt before I bought my truck. My brother and I both run shops so I was at his store for a oil change and they found that my power steering hose was leaking. Took it to ford and before I knew it they were done and also found another problem with it which was my master cylinder cap. They ordered a new one and call me up for them to fix it. With my 05 rc I have to take it to my shop and find a problem and then tell the local dodge dealer what to fix. Since I have been doing business with them it has been in there 3 times for oil cooler lines 2 pinion seals one output shaft seal 3 calipers. Every time they fix something I have to re-inspect and usally bring it back because there fix did not do anything.
 

·
Premium Member
Joined
·
11,158 Posts
it must be a shop thing...i hear of dealers doing great or efffing everythning up...i've had great success with my dealer...they don't ever try to sell me that crap you don't need, and the only times it's been there, i've had it back next day...slave cyl, flush trans, flush brakes, change diff fluid, just reg maintenance stuff, and they seem to always have all the stuff to fix it in stock...
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
One thing that sould never be overlooked....


Does your dealer have a Viper Mechanic
 

·
Premium Member
Joined
·
11,158 Posts
i think 2 certified vm's
 

·
Registered
Joined
·
122 Posts
New here and I hope this is in the right place. I'll try to make it short.

I have an '06 QC and started having problems about Sept. last year. My front brakes were sounding bad so I had the dealer order pads. When the dealer went to replace them, he discovered why they went out so quick. The calipers were sticking. Order new ones and replaced pads and calipers.

About a month later, brakes didn't feel right and brake light would come on about once a week (always before or after dealer hours), but would shut off when truck was shut off. Also had a little transmission slippage at lower speeds when letting off throttle and getting back on like the truck didn't know what gear to go into.

I took the truck in Nov. 2nd and went on a test drive with the service manager. (him driving) It slipped twice on the drive and I told him it doesn't slam into gear anymore like it used to. (they have never sold an srt-10 and mine is the only one taken there) I told him about the brakes and he said they felt fine. The next day I was called to pick-up the truck and was told everything was fine. I told him I was going to Vegas in a month I would take it to them while I was there.

Took the truck to Vegas and they gave it a quick diagnostic test and tried to give it quick fix as I couldn't leave it more than two days and they couldn't guarantee it'd be done by then. Said something wrong with a computer (said it has 7:wow:) and I was driving with power brakes out of the 70's. Took printout from Vegas to local dealer.

Was given the truck back 4 times during a monthlong period and only once did I make it out of the lot. (for 12 hours to drive it home and then to work the next morning)

Was finally given the truck back after 27 days and told it was okay to drive even though engine light stays on and brake light comes on constantly. Made then put it on paper. They said a computer was bad and they found a flaw in them, but wouldn't be making more until more trucks needed them replaced.

I've been driving the truck this way for approx. 6 weeks now and it runs rough, brakes drag when backing up, navigation doesn't work, and of course dealing with the constant beeping from the engine light, brake light, and navigation message.

Finally called Chrysler service and been given a case number and told to drop truck off at dealership and ask for a rental car and say nothing else (after they looked up the records) as the district manager would handle the rest.

Anyone else having these kinds of problems?
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
WOW...


No I haven't, what dealer have you been taking it to, maybe we can help find a better one in your area
 

·
Registered
Joined
·
122 Posts
WOW...


No I haven't, what dealer have you been taking it to, maybe we can help find a better one in your area
Fisher Dodge. It's the only Dodge dealer in my town. The next closest would be 2 1/2 hours either east or west whichever town I decided to go to.

I would love to leave it with the Vegas dealer I bought it from, but it's not really feasable. I told my local dealer last time I took it back to them, (after driving through their parking lot) I don't care how long it takes, just fix it! Like someone else said, the service adviser didn't even know how to start it. They even drove it out to give to me the first of the visits with the engine light on.
 

·
Premium Member
Joined
·
11,158 Posts
thats terrible!...as far as the problems go, i don't know what to say...other than you need a new dealer...
 

·
Registered
Joined
·
122 Posts
According to the dealer, or what they said Dodge techs. told them anyway, is it's a bad batch of computers that control the o2 sensor. They said I'd have to wait until they needed more as they wouldn't make just 1, they would need to make a bunch at a time. So I'm screwed until they get some more complaints basically.

They replaced that computer once and also the TPIM, but it didn't solve it.
 

·
Premium Member
Joined
·
11,158 Posts
i'd be effin irrate!!!!!!!:rawr:
 
1 - 20 of 70 Posts
Top