SRT10 Forum banner

41 - 60 of 70 Posts

·
Registered
Joined
·
122 Posts
So far no lights on and truck is running fine.

A little info. on the nav. It didn't work and the dealer said I needed a new disc so I ordered one. Sat. morning just for ****s and giggles I took the old disc. that came with the truck to a local game store and had it "cleaned". Cost $2.19 to have it done put it in unit and everything works fine. Saved me $219.00. If any of you have problems with them it's worth the try to have it cleaned first.
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
Nice to hear, glad you back up and running even with all the bad advice we tossed your direction

Jeff
 

·
Registered
Joined
·
122 Posts
Nice to hear, glad you back up and running even with all the bad advice we tossed your direction

Jeff
I didn't get any bad advise from here. The only bad advise I got was from the dealership.

I asked them if they knew about modifying my transmission with shift kit parts to get the shifts back and they said no. I asked if they could look into it and said they would. I don't expect to hear from them.

It was funny to hear the advisor constantly say "we aren't familiar with these trucks so we are learning as we go along." He said it numerous times when I said his SM sucked for telling me all this time nothing was wrong with my truck and me having to go to Vegas to get the ball rolling.:lew:
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
oops, for got the smilie in my post....:D

We do like having fun around here

I'm just glad you smiling again too

Jeff
 

·
Premium Member
Joined
·
11,158 Posts
that's really a bunch of horse sh!t that you went through...

but you're here now...haha...:D


























we actually work for that dealer and this website and needed new members here...so we kept you at bay so that you would join......:D




























ok, not really:D
 

·
Registered
Joined
·
122 Posts
that's really a bunch of horse sh!t that you went through...

but you're here now...haha...:D


























we actually work for that dealer and this website and needed new members here...so we kept you at bay so that you would join......:D




























ok, not really:D

It worked like a charm!:fing02:
 

·
Premium Member
Joined
·
11,158 Posts
damn...we ARE good...:D
 

·
Registered
Joined
·
122 Posts
Now I am truly lost! Been getting a brake light once in a while but doesn't last long enough to get to dealer.

It came on Sat. along with ABS light and made it to dealer and they hooked it up. I looked through the codes on the other thread, but they don't match up with any the dealer got off the truck. He said one was a low battery code. (it's been replaced once by dealer about 8 months ago)

They are as follows:

C1008
C1009
C2100
C2202
C2206
B1422


This is the original problem I had when this all started in Nov. Here I go again! They will only send an engineer out if the dealer has exausted all the options Dodge gives them and they won't send it to another city. (pride I'm sure)
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
C1008-BRAKE FLUID LEVEL CIRCUIT HIGH

C1009.... I cannot find

C2100–BATTERY VOLTAGE LOW


C2202-ORIGINAL VIN MISMATCH / MISSING


C2206-VEHICLE CONFIGURATION MISMATCH


B1422-AUDIO DVD READ ERROR/INOPERABLE DISC.
 

·
Registered
Joined
·
122 Posts
C1008-BRAKE FLUID LEVEL CIRCUIT HIGH

C1009.... I cannot find

C2100–BATTERY VOLTAGE LOW


C2202-ORIGINAL VIN MISMATCH / MISSING


C2206-VEHICLE CONFIGURATION MISMATCH


B1422-AUDIO DVD READ ERROR/INOPERABLE DISC.
Cool, thanks.

I guess it's safe to say the C1009 is a brake issue? Or could the brake fluid high code (C1008) trip the brake light and ABS light?

They told me before they had a brake fluid code, so I'm assuming that's the same one they got before.

I'm starting to think I got the 2006 lemon. :grumble:
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
I would be concerned with C2202 and C2206. If they are wrong in the computer, no telling what the other problems may be
 

·
Registered
Joined
·
122 Posts
I would be concerned with C2202 and C2206. If they are wrong in the computer, no telling what the other problems may be
They've had problems with the truck linking up with their computers before. The computer doesn't recognise the truck, the truck won't give the computer info., the truck computers don't communicate with each other, etc.
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
I'll try and do some more looking when I get home. My time will be limited, I had a water heater that fell apart over the weekend, I may be busy replacing that. I just don't like the "C" codes. I want to make sure of a few things.

So don't wait for me, but I'll try and post up as soon as I can

Jeff
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
Did some more looking but nothing has really jumped out at me...


Check for a loose plug
 

·
Registered
Joined
·
122 Posts
The dealer has said it's now the brake fluid sensor. The tech. working on it told the advisor he doesn't know and to get someone else or send it off and the SM said no, we're going to keep trying. The tech is the smart one here! I'm going to ask when I pick it up how long before they realise they're in over their heads and swallow their pride!

We'll see, but I don't think this is the end.
 

·
Registered
Joined
·
122 Posts
Was in for leaking power steering 4 weeks ago. Told me it was o-rings. Paid $80 bucks to have them replaced.

Took it back in two weeks ago for same problem and now overheating. Put new power steering pump on and still no fix. They said the fitting for the hose/pump is a separate part and is on backorder (like every part). still in shop and good news is there are only 6 hundred something backordered in front of me.:wow: :eek:mfg:

They told me the engine fan is run by the power steering fluid and pump. Is this correct? Is that why it's a high pressure line? I assume this is a hydraulic kind of thing?
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
Yes the fan is run by the power steering pump.

The best solution to you hose problem is after market hoses and I only know of one place to get them, call tony at 704-214-7849. Maybe some others will chime in with other locations.

I would hate to see your ride sit for a year
 

·
Registered
Joined
·
122 Posts
Yes the fan is run by the power steering pump.

The best solution to you hose problem is after market hoses and I only know of one place to get them, call tony at 704-214-7849. Maybe some others will chime in with other locations.

I would hate to see your ride sit for a year
I've tried to do that not only with the hose, (also backordered) and they won't do it because it's not a "chrysler certified part". They didn't like when I told them so what, you technician isn't Viper certified, but he's working on it!

It can sit and I'll try to get some payments out of them, in the mean time, I'll keep driving the rental on their expense keeping the miles off the truck. :fing02:
 

·
VIPEROLIGIST
Joined
·
13,625 Posts
Yea, pretty sad.......


When the excuse is "not a "Chrysler certified part". "


I think Chrysler needs to re-evaluate their certification process. Also, from what I've heard, hose replacement with after market products does not void the warranty. In fact I think (not positive) Chief had his hoses replaced at the dealer with after market hoses. (Disclaimer: every dealer has there own hostage rules)

And......


Unless they gave you an SRT as a rental, your getting ripped off

Jeff
 

·
Site SUPER Moderator
Joined
·
6,688 Posts
What I did with the oil lines was to carry them to my Dodge dealer and have them look at the hoses prior to install. They told me that they were great and would not hurt my warranty and approved the install. So when I had the oil changed 2 weeks ago the oil lines went on, and they got the money to install them.

It also gave me documentation that they had approved the install so they could not change their mind later... :)
 
41 - 60 of 70 Posts
Top