SRT10 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
My '04 RC has a lot of trouble shifting into reverse. The shifter kicks back out as the transmission grinds (worse sound in the world) when I release the clutch.

Previous owner (owned it for 6 years and 30k miles) replaced the master and the slave cylinders, and installed an aftermarket shifter (unknown brand) and a spec 3 clutch (rated for 1,000hp). I have had the truck for a couple of months and 1k miles. I have driven many of these trucks and never experienced these issues.

Once in a while, reverse does engage first try. Most of the time, though, reverse grinds and requires multiple tries. I then try double-clutching, triple-clutching, and sometimes these tricks work. Sometimes they don't. If I try multiple times and still no luck, I end up holding the shifter in reverse until reverse engages, and then I release the shifter. Once reverse is engaged, it works fine. All forward gears work fine without any problems.

Which transmission fluid is recommended by other RC owners?

Also, based on my symptoms, do you think it's a transmission problem or a shifter problem, or a spec 3 clutch
 

·
Registered
Joined
·
133 Posts
This is the oil I use in mine. I mix 1 quart of synthetic Lucas & the balance redline. Do not try ATF, won’t shift worth a dam.
 

·
Registered
Joined
·
133 Posts
These also made a huge difference. Took 10 minutes to install.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
These also made a huge difference. Took 10 minutes to install.
I'll try the fluids first thanks for the feedback.
 
1 - 5 of 5 Posts
Top