SRT10 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
4,025 Posts
Discussion Starter #1
Well after tightening those dam clamps on my magnaflow tighter than a ........... :rolleyes: ...well you get the idea, they still leaked. So I bought some new ones, nope still leaking.......took it apart and applied a sealing cement/goo, whatever it was called and more clamps, still leaked like the Titanic! :eek: Well I finally took it to a welding shop and had em seal up the sumbitch like like Fort Knox!!!! :) :) I can now say, "WOW" all that Viper v10 tone coming out the back has such a great tone!!! Shoulda had it done months ago....I think the leak was getting worse over time.....Well its all good now......Now I cant wait for the K and N kit......Darksyde has got me all excited with his testimonial..... ....

patrick
 

·
Registered
Joined
·
4,025 Posts
Discussion Starter #2
DarkSyde said:
Patrick, trust me bro, you have NO IDEA!!!! You will see soon bro, its like a different beast now!!! :cool: :D Im excited to see your feedback on it once you get it installed, just awesome! BTW, I also have my system all weded as well! :cool:

See you soon bro
TJ

Dude I am like a kid a Christmas with anticipation......Wormsterr cannot ship that kit fast enough......not to mention track season starts Feb. 19 :) I definatly will post some feedback when I get it in. Was the install simple? Any drilling, hammering, screaming and yelling jumping up and down frustration required when installing??

patrick
 

·
Registered
Joined
·
93 Posts
you putting in a k and n cold air? how does that compare to hennesey?
 

·
Registered
Joined
·
974 Posts
mauiSRT/10 said:
Well after tightening those dam clamps on my magnaflow tighter than a ........... :rolleyes: ...well you get the idea, they still leaked. So I bought some new ones, nope still leaking.......took it apart and applied a sealing cement/goo, whatever it was called and more clamps, still leaked like the Titanic! :eek: Well I finally took it to a welding shop and had em seal up the sumbitch like like Fort Knox!!!! :) :) I can now say, "WOW" all that Viper v10 tone coming out the back has such a great tone!!! Shoulda had it done months ago....I think the leak was getting worse over time.....Well its all good now......Now I cant wait for the K and N kit......Darksyde has got me all excited with his testimonial..... ....

patrick
I hear ya. I did the same a week after the magnaflow exhaust was installed.
 

·
Registered
Joined
·
4,025 Posts
Discussion Starter #5
kemon78 said:
you putting in a k and n cold air? how does that compare to hennesey?

Dont know much about the Henni. one except it was stainless or something and very pricey......I dont care about a stainless tube, I just want the power and function. Of course the tone it produces some real nice too!! :D

patrick
 

·
Registered
Joined
·
2,911 Posts
Darksyde,

Do you have to remove the extra Battery tray to install the K&N system??
If so I will have to relocate my VEC2. It is mounted on the side of it.
 

·
Registered
Joined
·
84 Posts
To those that had the Magnaflow CBs welded: Are they tack welded or welded all the way around? I had mine welded too, and they tack welded. I may be hearing things but it still sounds like I have a leak (although the truck still sounds much better than it did with just the clamps.) It seems to me that it may be difficult to weld them all the way around, at least on the tips anyway. Feedback is appreciated.
 

·
Registered
Joined
·
123 Posts
i had a leak on mine ,took it a part, put a fat bead of high temp silicone reclamped it and no leaks that was my last try ,if that did'nt work i would have had it welded ,but so far so good.
 

·
Registered
Joined
·
4,025 Posts
Discussion Starter #10
Bortego

I had em weld it all the way around, and even pointed that out to the welding dude.....I didnt want to have to come back and have em fix it a second time.....he mentioned it always comes back and bites him in the azz if he misses going all the way around. I did not have him weld the final piece with the chrome tips....that is still just held on with the clamps.


patrick
 

·
Registered
Joined
·
2,911 Posts
Patrick,

Would you please describe what your exhaust leak sounded like??

I have a hissing sound upon hard accelleration which I cant pin-point. It may be a leak. Wasn't there before the new system was installed??
 

·
Registered
Joined
·
4,025 Posts
Discussion Starter #12
Mark

I could hear just normal exhaust sounds under the doors espcially when pulling into the garage or next to any wall.....the sound would just bounce off the wall and sound all mushy....ick I hate that....another way to tell is by the moisture.....you should really only see it dripping out the back, not under it like I could always see. Of course I am in 80' weather with humidity...you may or may not have it depending on your local weather action. Before I welded it, I could actually see the sputtering of water coming out of the pipes at the clamps locations. It was really bad. Hope that helps out.

patrick
 

·
Registered
Joined
·
84 Posts
mauiSRT/10 said:
Bortego

I had em weld it all the way around, and even pointed that out to the welding dude.....I didnt want to have to come back and have em fix it a second time.....he mentioned it always comes back and bites him in the azz if he misses going all the way around. I did not have him weld the final piece with the chrome tips....that is still just held on with the clamps.


patrick

Thanks Patrick! I am going to take it in and have them weld it all the way around. Awesome!
 

·
Registered
Joined
·
123 Posts
it sounds like a flutter if you put your hand around by the clamps you can hear ot better and feel it leakingas well.
 
1 - 14 of 14 Posts
Top